1. [6448] Stockbroker Grapevine
한줄 후기 : 아직 까지 푼사람 두명이네 이 문제 왜 안풀지?
https://www.acmicpc.net/problem/6448
Stockbroker Grapevine 성공출처다국어
Unrated
난이도 제공: solved.ac — 난이도 투표하러 가기
시간 제한 |
메모리 제한 |
제출 |
정답 |
맞은 사람 |
정답 비율 |
1 초 |
128 MB |
3 |
2 |
2 |
66.667% |
문제
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.
Unfortunately for you, stockbrokers only trust information coming from their ‘trusted sources’. This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
입력
Your program will input data for different sets of stockbrokers.
Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.
출력
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input file is terminated by a set of stockbrokers containing ‘0’ (zero) people.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message ‘disjoint’. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
예제 입력 1
3 2 2 4 3 5 2 1 2 3 6 2 1 2 2 2 5 3 4 4 2 8 5 3 1 5 8 4 1 6 4 10 2 7 5 2 0 2 2 5 1 5 0 |
예제 출력 1
3 2 3 10 |
ㅋㅋㅋㅋㅋ이상한 욕심 생겨서 이 문제를 딱 1명이 풀었길래 그 기쁨을 없애주려고 나도 풀었다. 그래서 푼 사람 나랑 그 사람 2명 됨
사실 걍 구경간건데 문제가 너무 UCPC 예선 G번 루머랑 비슷해보여서 풀었다.
//AC
//BOJ 6448 Stockbroker Grapevine
//https://www.acmicpc.net/problem/6448
#include <iostream>
#include <cstring>
#define MAX 987654321
using namespace std;
int d[101][101];
int main(){
while(1){
int n;
scanf("%d", &n);
if(n==0) break;
bool check = true;
for(int i=1; i<=n ;i++){
for(int j=1; j<=n; j++){
d[i][j] = MAX;
}
}
int ans = MAX, res = MAX,t, a, b, min_stock = 0;
for(int i=1; i<=n; i++){
scanf("%d", &t);
for(int j=0; j<t; j++){
scanf("%d %d", &a, &b);
d[i][a] = b;
d[i][i] = 0;
}
}
for(int k=1; k<=n; k++){
for(int i=1; i<=n; i++){
for(int j=1; j<=n; j++){
d[i][j] = min(d[i][j], d[i][k]+d[k][j]);
}
}
}
for(int i=1; i<=n; i++){
res = 0;
bool dis = true;
for(int j=1; j<=n; j++){
if(d[i][j] == MAX){
dis = false;
break;
}
else{
if(res < d[i][j]) res = d[i][j];
}
}
if(ans>res && dis==true){
ans = res;
min_stock = i;
check = false;
}
}
if(check) printf("disjoint\n");
else printf("%d %d\n", min_stock, ans);
}
return 0;
}
문제 해석하면 주식 중개인 중 한명이 무슨 증권가 소문같은 걸 퍼뜨리려는데 다른 중개인들은 신뢰성 있는 소문만 믿는다고 한다. (걍 연결된 사람한테서 온 정보만 믿는다는 뜻) 무튼 그럼 우리가 출력할 것은 여러명의 주식 중개인 중 누굴 선택해야 최단 시간으로 모든 중개인에게 소문이 퍼지는 지 이다. 처음에 그래프 문제인가 하고 bfs로 구현했는데 틀림 ㅋㅋ그래서 최단경로 알고리즘으로 푼 문제이다.
주식 중개인의 최대 수가 100이기 때문에 플로이드 와샬 알고리즘 - O(n^3)을 써도 연산이 1000000 번 이라 충분히 1초안에 가능하다.
다익스트라는 구현하기 어려우니까 ;; 연산이 작다면 플로이드 와샬을 쓰자 ;; ㅋㅋㅋㅋㅋㅋㅋㅋㅋㅋ
처음에 코드를 짜다가 한번에 짜진 건 아니고 A->B, B->A 로의 경로가 없을 때 disjoint를 출력하라는 부분을 어떻게 할지 힘들었다.
결국 이 부분은 구글 교수님이 알려주심 무슨 중국인 분이 푼 코드에서 아이디어를 받아왔다. 감사합니다.
플로이드 와샬로 모든 정점간 최단 거리를 구해놓고, min 값을 골라주면 됨. 좀 재밌는 문제. 난 루머같은 문제가 재밌어
'DEV > PS' 카테고리의 다른 글
[19542] 전단지 돌리기 - UCPC 2020 본선 A번, c++ (0) | 2021.02.04 |
---|---|
[5582] 공통 부분 문자열, c++ (0) | 2021.02.04 |
[1197] 최소 스패닝 트리, c++ (0) | 2021.02.04 |
[2056] 작업, c++ (0) | 2021.02.04 |
solved ac 플래티넘5 달성 (0) | 2021.02.04 |